matplotlib dependencies; debian

Attempting to install matplotlib on a debian instance via pip install matplotlib gave me this error:-

numpy/__multiarray_api.h:1532: warning: ‘int _import_array()’ defined but not used

Apparently, it requires libfreetype6-dev and libpng-dev installed at distro-level so that it can generate free type and png images when plotting charts and diagrams.


sudo aptitude install libfreetype6-dev libpng-dev

solves our problem.

Moving on.